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About This 
Document
Testing with Palm OS® Simulator provides conceptual, guidance, and 
reference information for developers who want to use Palm OS 
Simulator to test their applications. 

This document is specific to the Palm OS 5.3 simulator. 

What This Volume Contains 
This volume has the following organization:

• Chapter 1, “Introducing Palm OS Simulator,” on page 1 
describes general concepts that will help you understand 
how to use Palm OS Simulator. 

• Chapter 2, “Using Palm OS Simulator,” on page 5 provides 
task information describing how to use Palm OS Simulator 
functions. 

• Chapter 3, “Palm OS Simulator User Interface Reference,” on 
page 27 documents the Palm OS Simulator menu commands 
and cross references relevant task information. 

Additional Resources
• Documentation 

PalmSource publishes its latest versions of this and other 
documents for Palm OS developers at 

http://www.palmos.com/dev/support/docs/ 

• Training 

PalmSource and its partners host training classes for Palm OS 
developers. For topics and schedules, check 

http://www.palmos.com/dev/training

http://www.palmos.com/dev/support/docs/
http://www.palmos.com/dev/training
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• Knowledge Base 

The Knowledge Base is a fast, web-based database of 
technical information. Search for frequently asked questions 
(FAQs), sample code, white papers, and the development 
documentation at 

http://www.palmos.com/dev/support/kb/

http://www.palmos.com/dev/support/kb/
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1
Introducing Palm OS 
Simulator 
This chapter provides conceptual information that will help you 
learn about Palm OS® Simulator. 

This chapter contains the following sections: 

• “What Is Palm OS Simulator?” on page 1 

• “How Does Palm OS Simulator Compare to Palm Simulator 
for Macintosh?” on page 4 

• “Prerequisites” on page 4 

What Is Palm OS Simulator? 
Palm OS Simulator is Palm OS recompiled for a desktop machine 
processor. Palm OS Simulator combines the following into a single 
execution environment: 

• Palm OS applications 

• Palm Application Compatibility Environment (PACE) 

• Palm OS system code

• An implementation of the Device Abstraction Layer (DAL)
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Figure 1.1 Palm OS Simulator Components 

Palm OS Applications 
Palm OS Simulator includes all of the built-in Palm OS applications, 
such as Address Book, Date Book, Memo Pad, and To Do List. The 
built-in Palm OS applications are included in the Simulator ROM 
file. 

You can add other Palm OS applications to a Simulator session as 
well. For more information, see “Installing Applications” on 
page 17. 

Palm OS System Code 
Palm OS Simulator includes all of the Palm OS 5 system code, 
compiled to run on Windows. 

Palm OS Runtime Services 

Palm OS Simulator implements the Palm OS 5 runtime services by 
using desktop system library files (DLLs). These DLLs are located in 
the Palm OS Simulator directory, and are loaded when the code that 
they contain needs to be executed. 
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Communication Stacks 

Palm OS Simulator uses the communication stacks for NetLib and 
Telephony components. Palm OS Simulator can optionally redirect 
NetLib calls to the host machine TCP/IP stack. 

Palm Application Compatibility Environment 
When you use Simulator to test your existing 68K application, the 
application is run in the Palm Application Compatibility 
Environment (PACE). PACE provides a 68K application 
environment that is equivalent to Palm OS 4.1. 

PACE handles the data translation required for a 68K application to 
run on Palm OS 5. For example, 68K applications read and write 
data in big-endian mode, but Palm OS 5 views data in little-endian 
mode. When a 68K application calls a Palm OS function, PACE 
handles the translation of the parameters, objects, and structure 
layouts so that existing applications do not have to be updated to 
handle the change of endianness. PACE creates “shadow structures” 
for the 68K application’s data that allow the 68K application to run 
under Palm OS 5. 

Device Abstraction Layer 
The Device Abstraction Layer (DAL) is responsible for insulating 
Palm OS from the underlying system and hardware. By running 
Palm OS on top of the DAL for the desktop machine, Palm OS 
Simulator recreates the Palm OS program execution environment in 
the desktop machine. 

Applications that run in this environment see the same functionality 
provided by the Palm OS managers, libraries, and applications as on 
a Palm Powered handheld. 

Because Palm OS Simulator runs on a desktop machine, it can be 
integrated with the desktop tools for Palm OS development. This 
integration allows full source level debugging of the code that is 
targeted for Palm Powered handhelds. 
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How Does Palm OS Simulator Compare to Palm 
Simulator for Macintosh? 

Palm OS Simulator has significant advantages over the Macintosh 
simulator in use with Palm OS 4.0: 

• All of the applications and shared libraries that can be loaded 
onto a handheld can be loaded in Palm OS Simulator at the 
same time. This allows analyzing the interactions between 
the applications, shared libraries, and Palm OS with a much 
better accuracy than before. 

• Palm OS Simulator supports multi-threading. 

• Palm OS Simulator runs exactly the same Palm OS code that 
runs on a Palm Powered handheld. The only difference 
between Palm OS running on a handheld and Palm OS 
Simulator is the DAL. 

• The Macintosh simulator required that components be 
statically linked together. Because Palm OS Simulator does 
not have this requirement, the simulation reproduces 
accurately the Palm OS runtime architecture on top of the 
desktop machine system. 

Prerequisites 
Palm OS Simulator runs on Windows NT 4 x86, Windows 2000, 
Windows XP, Windows 98, and Windows ME. 

Palm OS Simulator is flexible enough to be used with most C/C++ 
development chains, with or without an associated integrated 
development environment (IDEs such as Visual C++). 
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2
Using Palm OS 
Simulator 
This chapter provides guidance and reference information that will 
help you use Palm OS® Simulator. 

• “Installing Palm OS Simulator” on page 6 

• “Starting Palm OS Simulator” on page 6 

• “Specifying Command Line Arguments” on page 7 

• “Using the Initialization File” on page 14 

• “Loading ROM Images” on page 15 

• “Running Palm OS Simulator” on page 16 

• “Using Communication Functions” on page 18 

• “Using External Debug Tools with Palm OS Simulator” on 
page 19 

• “Using Gremlins” on page 24 

• “Using the Host Control API” on page 26 
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Installing Palm OS Simulator 
Palm OS Simulator consists of the following: 

• The executable file: PalmSim.EXE 

• A ROM file 

• The DLLs required by the ROM file 

The ROM file is specific to Palm OS Simulator; the ROM file is not 
the same as ROM files used with Palm OS Emulator. ARM-based 
PRCs and 68K-based PRCs are embedded in this ROM file. 
However, ARM-based PRCs don't really contain code; rather, they 
reference external DLL files. As a result, there will be at least one 
DLL per ARM-based application or shared library. 

The DLLs required by the ROM file can be in the same directory as 
the executable file PalmSim.EXE, or in the subfolder for the locale-
specific ROM file (such as enUS or jpJP). 

To use tracing functions with Palm OS Simulator, you need to have 
the files PalmTrace.DLL and Reporter.EXE in a directory 
included in the PATH environment variable. 

Starting Palm OS Simulator 
To start Palm OS Simulator, run PalmSim.EXE. The first time you 
start Palm OS Simulator, you are asked to select a ROM file. 

You can also start Palm OS Simulator by dragging and dropping a 
Simulator ROM file onto the PalmSim.EXE icon. (Note again that 
the Simulator ROM file is not the same as the ROM files used for 
Palm OS Emulator. You should not drop an Emulator ROM file on 
the PalmSim.EXE icon.) 

When Palm OS Simulator starts, the main window is displayed, as 
shown in Figure 2.1. 
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Figure 2.1 Palm OS Simulator’s Main Window 

Specifying Command Line Arguments 
You can supply the session parameters for Palm OS Simulator as 
command line options. For example: 

PalmSim.EXE -rom:NTFullDbg.rom 

Table 2.1 shows the options that you can specify with the command 
line version of Palm OS Simulator. 

NOTE: The command line option are not case sensitive, but the 
values specified for the options might be (for example, the 4-
character application creator ID for the -appcreator option). 



Using Palm OS Simulator
Specifying Command Line Arguments

8 Testing with Palm OS Simulator

Table 2.1 Command Line Options 

Option Syntax Parameter Values 

-rom:romname romname - The name of the ROM file. 

If you do not specify a value for this 
option when you first start Simulator, 
Simulator will open a dialog box asking 
for you to specify a ROM file. If you do 
not specify a value for this option on 
subsequent uses of Simulator, Simulator 
will load the ROM file name from the 
initialization file. 

-ram:size size - An integer value indicating the 
amount of RAM to emulate during the 
session, specified in kilobytes. The default 
is 8192. 

For more information, see 
“Memory>RAM Size” on page 35. 

-dyn:size size - An integer value indicating the 
amount of dynamic heap to emulate 
during the session, specified in kilobytes. 
The default is 512. 

For more information, see 
“Memory>Dynamic Heap Size” on 
page 36. 

-sound:[on|off] Activate or deactivate sound output. The 
default is off. 

For more information, see “Enable 
Sound” on page 39. 
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-storageprotection:[on|off] Activate or deactivates write protection 
for the storage memory. The default is 
off. 

For more information, see 
“Memory>Storage Is Write-Protected” on 
page 36. 

-storagesnapshotfile:ssfname ssfname - The name of the storage 
snapshot file (SSF), indicating the saved 
storage snapshot that you want Simulator 
to load at startup or upon hard reset. 

For more information, see “Storage 
Menu” on page 40. 

-appcreator:xxxx xxxx - A four-character Creator ID 
indicating the application to start. 

For more information, see Chapter 2, 
“Using AppCreator to Start an 
Application,” on page 17. 

-bitdepth:[1|2|4|8|16] Screen bit depth. The default is 8. 

For more information, see 
“Display>Allowed Screen Depths” on 
page 34. 

-zoom:[1|2|3|4] Magnification level. The default is 2. 

For more information, see 
“Display>Magnification” on page 35. 

Table 2.1 Command Line Options  (continued)

Option Syntax Parameter Values 
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-alwaysontop:[on|off] Indicates whether the Simulator window 
should stay in front of other windows on 
the desktop. The default is off. 

For more information, see 
“Display>Always on Top” on page 35. 

-windoworiginx:integer integer - Specifies Simulator’s 
horizontal distance from the left of the 
screen when the window is opened. The 
default is 0. 

-windoworiginy:integer integer - Specifies Simulator’s vertical 
distance from the top of the screen when 
the window is opened. The default is 0. 

-cradleport:COMx COMx - The communications port used to 
talk to the cradle. 

For more information, see 
“Communication>Communication Ports” 
on page 37.

-cradleporttype:type type - The type of port used for 
communication with the cradle. The 
default is Standard RS-232.

For more information, see 
“Communication>Communication Ports” 
on page 37.

-infraredport:[COMx|None] COMx - The communications port used for 
infrared. 

For more information, see 
“Communication>Communication Ports” 
on page 37.

Table 2.1 Command Line Options  (continued)

Option Syntax Parameter Values 
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-infraredporttype:type type - The type of port used for infrared 
communication. 

For more information, see 
“Communication>Communication Ports” 
on page 37.

-68kdebuggerport: 
[host:port|None] 

host - The name of the host used for the 
68K debugger. 
port - The port used for the 68K 
debugger.

Example: 
-68KDebuggerPort: 
localhost:2000

For more information, see 
“Communication>Communication Ports” 
on page 37.

-68kdebuggerporttype:type type - The type of port used for the 68K 
debugger. The default is TCPIP. 

For more information, see 
“Communication>Communication Ports” 
on page 37.

-additionalports:COMx COMx - Additional communications ports. 

For more information, see 
“Communication>Communication Ports” 
on page 37. 

Table 2.1 Command Line Options  (continued)

Option Syntax Parameter Values 
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-usehostbatteryinfo:[on|off] Indicates whether the changes in the host 
machine should be indicated in the 
battery state of the handheld (for 
example, when you want to have the 
battery state of a laptop computer 
mapped to the Palm OS Simulator 
display). The default is off. 

For more information, see “Battery” on 
page 38. 

-redirectnetlibcalls:[on|off] Indicates whether you want to redirect 
NetLib calls to the host machine’s TCP/IP 
stack. The default is off.

For more information, see 
“Communication>Redirect NetLib Calls 
to Host TCP/IP” on page 37. 

-allowedscreendepths:mask mask - A number representing the screen 
depths you want to allow. The default is a 
mask representing all possible depths. 

For more information, see 
“Display>Allowed Screen Depths” on 
page 34. 

-extendedmemorychecks:[on|off] Indicates whether PACE should do 
extended checks of applications’ use of 
system memory. The default is off. 

For more information, see 
“Memory>PACE Extended Checks” on 
page 36. 

Table 2.1 Command Line Options  (continued)

Option Syntax Parameter Values 
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-directscreenaccess:[on|off] Indicates whether the installed 
applications have access to the LCD 
screen buffer. The default is off. 

For more information, see 
“Display>Allow Direct Screen Access” on 
page 35. 

-screendensity: [108|144] Sets the density of the display screen. The 
default is 108. 

For more information, see 
“Display>Resolution” on page 35. 

-screenwidth: [160|240|320] Sets the width of the display screen. The 
default is 240. 

For more information, see 
“Display>Resolution” on page 35. 

-screenheight: [160|220 
|240|320|480] 

Sets the height of the display screen. The 
default is 240. 

For more information, see 
“Display>Resolution” on page 35. 

-hassilkscreen: [on|off] Indicates whether the display screen has a 
dynamic input area. The default is off. 

For more information, see 
“Display>Resolution” on page 35. 

Table 2.1 Command Line Options  (continued)

Option Syntax Parameter Values 
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Using the Initialization File 
The command line arguments can be set in the Simulator 
initialization file, palmsim.ini. Any options specified on the 
command line will override the initialization file settings. 

When you exit Simulator, the session’s values are written to 
palmsim.ini for the next time you start Simulator. 

NOTE: The initialization file options use an equals sign (=) to 
separate the option from the value, rather than the colon 
character (:) used in the command line version. Also, boolean 
values in the initialization file are indicated using 0 and 1 rather 
than off and on. 

Listing 2.1 Sample palmsim.ini File 

[Settings] 
ROM=C:\Palm OS Simulator\Release\enUS\NTFull_enUS.rom 
RAM=8192 
DYN=1024 
Sound=0 
StorageProtection=0 
Zoom=2 
BitDepth=8 
DebugThroughTCP=1 
AlwaysOnTop=0 
UseHostBatteryInfo=1 
WindowOriginX=681 
WindowOriginY=8 
RedirectNetLibCalls=0 
AllowedScreenDepths=32907 
LastSilkScreen= 
AppCreator= 
CradlePort= 
CradlePortType=Standard RS-232 
InfraredPort= 
InfraredPortType= 
68KDebuggerPort=localhost:2000 
68KDebuggerPortType=TCP/IP 
AdditionalPorts= 
TraceTarget=tcp:localhost:25998 
GremlinsFromValue=0 
GremlinsToValue=0 
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GremlinsSwitchAfter=0 
GremlinsSwitchAfterValue=0 
GremlinsStopAfter=0 
GremlinsStopAfterValue=0 
GremlinsSelectedApps= 
GremlinsFirstApp= 
GremlinsAllowScreenUpdates=1 
GremlinsWindowOriginX=0 
GremlinsWindowOriginY=0 
LogErrorMessages=0 
DirectScreenAccess=0 
ExtendedMemoryChecks=1 
LastStorageSnapshot=storage snapshot.ssf 
StorageSnapshotFile=mysnapshot.ssf
ScreenDensity=108 
ScreenWidth=240 
ScreenHeight=240 
HasSilkScreen=0 

Loading ROM Images 
When you first run Palm OS Simulator, you can specify the ROM 
image filename using the -rom command line option. If you do not 
specify a value for this option, Simulator will open a dialog box 
asking for you to specify a ROM file. 

When you restart Simulator, it will assume you want to use the 
ROM file that you specified when you first started Simulator. 

To run Simulator with a different ROM file, you can do one of the 
following:

• Change the ROM option value in the palmsim.ini file. 

• Specify a new value using the -rom command line option. 

• Hold down the SHIFT key when you start Simulator. Then, 
Simulator will open a dialog box asking for you to specify a 
ROM file. 

• Drag and drop a ROM file onto the PalmSim.EXE icon. 
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Running Palm OS Simulator 
This section provides an overview how to use Palm OS Simulator. 

Palm OS Simulator Display 
The Palm OS Simulator display looks very much like a real Palm 
Powered handheld device. You can use your mouse to perform 
actions that you perform with the stylus on handheld devices, and 
you can use the menus to access Palm OS Simulator functions. 

Displaying Menu Items 
Right-click (use mouse button 2) on the Palm OS Simulator screen 
display to access the menu items. The Palm OS Simulator menu 
displays, as shown in Figure 2.2. 

Figure 2.2 The Palm OS Simulator Menu

For more information about the Palm OS Simulator menu items, see 
“Menu Reference Summary” on page 27. 

Entering Data 
Palm OS Simulator supports handwriting recognition. You can 
draw Graffiti® or Graffiti 2 characters (depending on the OS version) 
using a mouse. 

Palm OS Simulator also supports keyboard input. When a field is 
active, you can use the keyboard to enter text. You can also use 
keyboard equivalents for hardware buttons and other functions. For 
more information, see “Keyboard Equivalents Reference” on 
page 42. 
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Installing Applications 
To install Palm OS applications, you can either use the Install menu 
item or drag and drop files onto Simulator. 

Using the Install Menu Item 

Use Install>Database to open the Install Database dialog box. You 
can install a single PRC, PDB, or PQA file, or you can use SHIFT-click 
to select multiple databases for installation. You will receive a 
warning message if Palm OS Simulator cannot use a PRC, PDB, or 
PQA file. 

Using Drag and Drop 

Drag and drop PRC, PDB, and PQA files onto the Palm OS 
Simulator main window. You will receive a warning message if 
Palm OS Simulator cannot use a PRC, PDB, or PQA file. 

Using AutoRun, AutoLoad, and 
AutoRunAndQuit 
Simulator also supports the AutoRun, AutoLoad and 
AutoRunAndQuit features that are available with Palm OS 
Emulator. 

To use AutoRun:

• Create a subdirectory of the Simulator directory called 
AutoRun. 

• Place the PRC, PDB, and PQA files that you want to 
automatically run in the AutoRun directory.

• When you start Simulator, Simulator will automatically load 
the PRC, PDB, and PQA files. 

To use AutoLoad or AutoRunAndQuit, follow the steps listed above 
using AutoLoad or AutoRunAndQuit as the directory name rather 
than AutoRun. 

Using AppCreator to Start an Application 
To have Simulator switch to a specific application at startup, you 
can either set the AppCreator value to the application’s creator ID 
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in the palmsim.ini file, or you can specify the -AppCreator 
command line argument. See “Specifying Command Line 
Arguments” on page 7 for more information about command line 
arguments. 

Starting Simulator with a Storage Snapshot 
File 
To have Simulator load a specific storage snapshot file at startup or 
upon hard reset, you can either: 

• Set the storagesnapshotfile value in the palmsim.ini 
file

• Specify the -StorageSnapshotFile command line 
argument. 

Note that the storage image size specified by the storage snapshot 
file must match the current storage size setting. 

See “Specifying Command Line Arguments” on page 7 for more 
information about command line arguments. For more information 
about storage snapshot files, see “Storage Menu” on page 40. 

Using Communication Functions 
Palm OS Simulator supports the following communication 
functions. 

Performing a HotSync Operation 
You can perform a HotSync® operation through serial connection, 
through IrDA, and through TCP. 

HotSync Operation with Two Serial Ports

1. Connect the serial ports with a NULL serial cable. 
2. Set the properties for the HotSync application to perform a 

local HotSync operation with one of the serial ports. 
3. Using the Simulator menu Settings > Communications > 

Communication ports, set the cradle’s port to Standard 
RS232 bound to the other serial communication port. 
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HotSync Operation with One Serial Port 

1. Select the Simulator menu Settings>Communications> 
Redirect NetLib calls to TCP/IP in order to redirect the 
NetLib calls to the host machine’s TCP/IP stack. 

2. Using the Simulator menu Settings>Communications> 
Communication ports, set the cradle’s port to TCP/IP bound 
to localhost:9. 

3. In the HotSync settings for the host computer, enable 
Network Hotsync. 

4. In the HotSync application in the simulation session, set the 
following settings: 
– Tap Modem.

– Select Options>Modem Sync Prefs and tap Network. 
Tap OK to save the changes. 

– Select Options>LANSync Preferences and tap 
LANSync. Tap OK to save the changes.

– Select Options>Primary PC Setup and enter 127.0.0.1 
as the Primary PC Address. Tap OK to save the changes. 

– Select Options>Connection Setup and select Cradle/
Cradle. Tap Done to save the changes. 

– Tap Select Service to set your service preferences, and 
then tap Done. 

Using External Debug Tools with Palm OS 
Simulator 

Palm OS Simulator can be used with a 68K debugger to examine the 
state of the 68K emulated applications. 

Palm OS Simulator is a debug target, just as an actual device or 
Palm OS Emulator. You can use Palm Debugger, Metrowerks 
CodeWarrior Debugger, or any other debugger you are used to 
using with Palm OS Emulator. 

For example, you can use Palm OS Simulator with Metrowerks 
CodeWarrior by following these steps: 

• In Palm OS Simulator, select Settings>Communication> 
Redirect NetLib Calls to Host TCP/IP, as shown in Figure 
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2.3, in order to redirect the NetLib calls to the host machine’s 
TCP/IP stack. 

Figure 2.3 Redirect NetLib Calls to Host TCP/IP 

• Also in Palm OS Simulator, select Settings> 
Communication>Communication ports to bind the 68K 
debugger transport to localhost:2000, as shown in 
Figure 2.4 on page 21. 



Using Palm OS Simulator
Using External Debug Tools with Palm OS Simulator

Testing with Palm OS Simulator 21

Figure 2.4 Setting the 68K Debugger Transport Values 

• In CodeWarrior, select Edit>Preferences to display the IDE 
Preferences dialog box, shown in Figure 2.5 on page 22. 



Using Palm OS Simulator
Using External Debug Tools with Palm OS Simulator

22 Testing with Palm OS Simulator

Figure 2.5 IDE Preferences Dialog Box 

• Click PalmDebugger Settings in the IDE Preference Panels 
tree to display the PalmDebugger Settings panel. 

• Set the Target selection to be Palm OS Emulator. 

• Click Choose next to the Location entry field.

• Use the Choose File dialog box to select the PalmSim.exe 
executable. 

• Select the setting Use TCP/IP connection to emulator. 
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Figure 2.6 Setting the CodeWarrior IDE Preferences 

• Click Apply or OK to set your new values so that Palm OS 
Simulator will be used to run your application rather than 
Palm OS Emulator. 

NOTE: Simulator supports Metrowerks CodeWarrior for Palm 
OS Version 7 and later. 
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Using Gremlins 
Palm OS Simulator’s Gremlins testing is similar to the Gremlins 
testing provided by Palm OS Emulator. 

To use Gremlins, use the Gremlins menu item to display the 
Gremlins dialog box, as shown in Figure 2.7 on page 24. In this 
dialog box, you specify the characteristics of the Gremlins you want 
to use to test your application. 

Figure 2.7 Gremlins Dialog Box 
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Applications and Panels 
Use this multiple selection list to select the set of applications and 
OS panels that the Gremlins are to run. You can select a single 
application or panel, a group of applications and panels, or all 
applications and panels. 

First Application 
Use this drop-down list to select the first application the Gremlins 
are to run. 

Random Seed 
Use the From entry field to set the seed for the Gremlin pseudo-
random number generator. 

NOTE: The To entry field is not yet supported. 

Events 
Use the Stop after entry field to set the maximum number of events 
for each Gremlin. Simulator stops running each Gremlin after it 
posts this many events, or after it terminates with an error. 

NOTE: The Switch after entry field is not yet supported.

Control 
This area allows you to start, step, and stop Gremlin testing. It also 
allows you to monitor Gremlin testing as it is happening. 
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Using the Host Control API 
A subset of the host control API, as recognized by Palm OS 
Emulator, is supported in Palm OS Simulator: 

• Standard C Library wrapper selectors

• Remote Procedure Call (RPC)

• External tracing tool support and all selectors required by 
HostFS.prc. 

To determine whether a specific host control function is supported, 
use the HostIsSelectorImplemented function. 

For more information about the host control API, see Using Palm OS 
Emulator. 
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3
Palm OS Simulator 
User Interface 
Reference 
This chapter provides a reference for the Palm OS® Simulator user 
interface elements. 

Menu Reference Summary 
The Palm OS Simulator menus include: 

• “Reset Menu” on page 28 

• “View Menu” on page 28 

• “Install Menu” on page 31 

• “Gremlins Menu” on page 32 

• “Settings Menu” on page 34 

• “Storage Menu” on page 40 

• “About Menu” on page 41 

• “Exit Menu” on page 41 
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Displaying the Palm OS Simulator Menu Items 
Right-click (use mouse button 2) on the Palm OS Simulator screen to 
display the menu items. 

Figure 3.1 Palm OS Simulator Menu Items

Reset Menu 
Use the Reset menu to perform a reset of the current simulation 
session. 

Soft 
Performs a soft reset of the current simulation session. This is 
equivalent to pressing the reset button on the back of a handheld. 

Hard 
Performs a hard reset of the current simulation session. A hard reset 
erases all data in the simulation session, restoring it to the 
equivalent of a new handheld. 

View Menu 
Use the View menu to view information about the installed 
databases, the contents of the heap, or the user interface events. 
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Databases 
Opens the Databases dialog box, shown in Figure 3.2 on page 29, 
which lists the databases included in the current simulator session. 

Figure 3.2 View>Databases Dialog Box 

Using the Databases Dialog Box 

• Click on the plus sign icons to view the details of a database. 

• Click on the minus sign icons to close the details view of a 
database. 

• For databases that have contents, click on a record to view 
the record’s contents in the right view pane. 

NOTE: The dimmed databases in the Databases dialog box are 
the read-only databases. 
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Heaps 
Opens the Heaps dialog box, shown in Figure 3.3 on page 30, which 
displays the contents of the heaps for the current simulator session. 

Figure 3.3 View>Heaps Dialog Box 

Using the Heaps Dialog Box 

• Use the View>Refresh menu to refresh the heap information 
that is displayed. 

• Use the View>Lock menu to keep the heap information from 
being updated. 

• Use the View>Unlock menu to allow the heap information to 
be updated. 

• When viewing the ROM heap, click on a chunk number to 
view the contents of a chunk in the bottom view pane. 
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Events 
Opens the Events dialog box, shown in Figure 3.4, which displays 
the user interface events for the current simulator session. 

Figure 3.4 View>Events Dialog Box 

Using the Events Dialog Box 

• Use the View>Clear menu to clear the events information 
that is displayed. 

• Use the View>Lock menu to keep the events information 
from being updated. 

• Use the View>Unlock menu to allow the events information 
to be updated. 

Install Menu 
Use the Install>Database menu to install PRC, PDB, and PQA files. 
The Install>Database menu displays the Install Database dialog 
box, shown in Figure 3.5. 
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Figure 3.5 Install Database Dialog Box 

Using the Install Database Dialog Box 

• To install a single database, select a PRC, PDB, or PQA file 
and click Open. 

• To install multiple databases, use SHIFT-click to select 
multiple PRC, PDB, and PQA files and click Open. 

Gremlins Menu 
Use the Gremlins menu to perform Gremlin testing. The Gremlins 
menu displays the Gremlins dialog box, as shown in Figure 3.6. 



Palm OS Simulator User Interface Reference
Gremlins Menu

Testing with Palm OS Simulator 33

Figure 3.6 Gremlins Dialog Box 

For more information on using Gremlins, see “Using Gremlins” on 
page 24. 
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Settings Menu 
Use the Settings menu to change the settings for the current 
simulation session. 

Display>Color Depth 
Set the color depth for this simulation session:

• 2 colors

• 4 colors

• 16 colors

• 256 colors 

• 65536 colors 

NOTE: If you change the setting for Color Depth, Palm OS 
Simulator will perform a soft reset. 

Display>Allowed Screen Depths 
Opens the Allowed Screen Depths dialog box, shown in Figure 3.7, 
so that you can set the screen depths appropriate for this simulation 
session. 

Figure 3.7 Allowed Screen Depths Dialog Box 

NOTE: If you change the setting for Allowed Screen Depths, 
Palm OS Simulator will perform a soft reset. 
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Display>Allow Direct Screen Access 
Indicates whether installed applications are allowed to have direct 
access to the LCD screen buffer. 

Display>Magnification 
Sets the scaling size for the simulation session display:

• 1:1 

• 2:1 

• 3:1 

• 4:1 

Display>Always on Top 
Indicates whether the Simulator window should stay on top when 
you switch to other application windows. 

Display>Resolution 
Sets the pixel resolution for the simulation session display. 

• 160x160 - Select this setting for a low density display. 

• 160x220 - Select this setting for a low density display with a 
dynamic input area. 

• 240x240 - Select this setting for a one-and-one-half (1.5X) 
density screen. 

• 240x320 - Select this setting for a one-and-one-half (1.5X) 
density screen with a dynamic input area. 

• 320x320 - Select this setting for a double density screen. 

• 320x480 - Select this setting for a double density screen with a 
dynamic input area. 

Memory>RAM Size 
Sets the RAM size for this simulation session: 

• 1 MB 

• 2 MB 



Palm OS Simulator User Interface Reference
Settings Menu

36 Testing with Palm OS Simulator

• 4 MB 

• 8 MB 

• 16 MB 

• 32 MB 

• 64 MB 

• 128 MB

NOTE: If you change the value of the RAM Size setting, Palm 
OS Simulator will perform a hard reset.

Memory>Dynamic Heap Size 
Sets the dynamic heap size for this simulation session: 

• 512 KB 

• 1024 KB 

• 2048 KB 

NOTE: If you change the value of the Dynamic Heap Size 
setting, Palm OS Simulator will perform a hard reset.

Memory>Storage Is Write-Protected 
Indicates whether the storage is write-protected for this simulation 
session. 

NOTE: If you change the setting for Storage Is Write-Protected, 
Palm OS Simulator will perform a soft reset. 

Memory>PACE Extended Checks 
Indicates whether you want the extra memory testing provided 
with PACE’s extended checking of memory access. 
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PACE (Palm Application Compatibility Environment) checks 
pointer values before passing them to API functions, and creates an 
alert for unexpected NULL pointer values. 

Select this setting to keep PACE’s standard behavior; clear this 
setting to relax PACE’s checking of NULL pointers. 

For more information about PACE, see“Palm Application 
Compatibility Environment” on page 3. 

Communication>Communication Ports 
Displays the Communication Ports dialog box, shown in Figure 3.8, 
so that you can change the communication port settings for the 
current simulation session. 

Figure 3.8 Communication Ports Dialog Box 

Communication>Redirect NetLib Calls to Host 
TCP/IP 
Indicates whether NetLib calls should be redirected to the host 
TCP/IP communication stack. 
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Battery 
Displays the Battery dialog box, shown in Figure 3.9, so that you can 
change the simulated battery settings. 

Figure 3.9 Battery Dialog Box 

Using the Battery Dialog Box 

• Select the Kind of battery you want to simulate from the 
supported list: 

– Alkaline: a hydrous alkaline (non-rechargeable) battery 

– NiCad: a rechargeable nickel cadmium battery 

– LiIon: a rechargeable lithium ion battery 

– RechAlk: a rechargeable alkaline battery 

– NiMH: a rechargeable nickel metal hydride battery 

– LiIon1400: a rechargeable lithium ion battery with a 
capacity of 1400 mAh (milliamperes hours) 

• The battery State is dependent on the Level selected:

• If the battery type is LiIon or LiIon1400 and the Plugged 
in setting is selected, then the simulated device will be in 
battery charging mode, as shown in Figure 3.10 on page 39. 

State Level 

Normal 100 to 21 

Low 20 to 11 

Critical 10 to 6 

Shutdown 5 to 0 
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Figure 3.10 Battery Charging Mode 

Enable Sound 
Select Enable Sound to enable sound simulation for this simulation 
session. 

NOTE: If you change the value of the Enable Sound setting, 
Palm OS Simulator will perform a soft reset. 
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Storage Menu 
Use the Storage menu to load and save a storage snapshot file (SSF 
file). 

Load 
Opens the Load Storage Heap Snapshot dialog box, shown in Figure 
3.11, so that you can load the storage heap with contents that were 
previously saved to a storage snapshot file (SSF file). 

Figure 3.11 Load Storage Heap Snapshot Dialog Box 

Save 
Opens the Save Storage Heap Snapshot dialog box, shown in Figure 
3.12, so that you can save the current contents of the storage heap to 
a storage snapshot file (SSF file). 
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Figure 3.12 Save Storage Heap Snapshot Dialog Box 

About Menu 
Use the About menu to get release information about Palm OS 
Simulator. 

Exit Menu 
Use the Exit menu to exit Palm OS Simulator. 

When you exit Simulator, the current option values are written to 
the file palmsim.ini for the next time you start Simulator. For 
more information on using palmsim.ini, see Chapter 2, “Using 
the Initialization File,” on page 14. 
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Keyboard Equivalents Reference 
Because it is more difficult to use the mouse in place of a handheld 
stylus, Palm OS Simulator provides keyboard equivalents for many 
functions. 

Hardware Buttons 
The keyboard equivalents for handheld hardware buttons is similar 
to the key mapping recognized by Palm OS Emulator. 

Additional Keyboard Functions 
In addition to hardware button equivalents, Palm OS Simulator 
provides the following functions that can be invoked from the 
keyboard. 

Table 3.1 Keyboard Equivalents for Hardware Buttons 

Hardware Button Keyboard Equivalent 

Power (on/off) ESC 

Hardware button 1 (Date Book 
application)

F1 

Hardware button 2 (Address 
Book application) 

F2 

Hardware button 3 (To Do List 
application) 

F3 

Hardware button 4 (Memo Pad 
application) 

F4 

Scroll up PGUP 

Scroll down PGDN 
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Table 3.2 Palm OS Simulator Keyboard Functions 

Function Keyboard Equivalent

Enter a shortcut character and a 
period. 

PAUSE | ATTN

Display the pop-up menu. CTRL + A 

Enter the menu command 
stroke. 

CTRL + C 

Enter a confirmation character. CTRL + D 

Tap the Applications icon. CTRL + E 

Display the onscreen keyboard 
(Tap the “abc” in the input 
area). 

CTRL + F 

Tap the Find icon. CTRL + I 

Tap the Calculator icon. CTRL + K 

Enter a linefeed character. CTRL + M 

Tab to the next field. CTRL + N 

Tab to the previous field. CTRL + P 

Perform a soft reset. CTRL + R 

Perform a hard reset. CTRL + SHIFT + R 

Power (on/off) CTRL + S

Enter the 68K debugger. CTRL + PAUSE 
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